aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-02 14:20:46 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-02 14:20:46 +0000
commit7eb5322b5bdb438ec5ca5751e4394adcd20cc824 (patch)
treeff3bbe9b1a68e4aaa64837ea242cb9eb320a2ed0 /configure.ac
parent933ddf410aee42eac51dfd9f3d5e5c4a98efaf22 (diff)
actually check for a function present in libiconv (don't know how this test could have worked before) and don't do the check on Linux/GNU systems because libiconv is not present there and attempting to link with '-liconv' always fails (it's not necessary as the iconv functionality is always available)
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@95817 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c7aa642a9..1a64cf514 100644
--- a/configure.ac
+++ b/configure.ac
@@ -618,7 +618,11 @@ if test "${USE_GSM}" != "no"; then
fi
fi
-AST_EXT_LIB_CHECK([ICONV], [iconv], [libiconv], [iconv.h])
+if test "${host_os}" != "linux-gnu" ; then
+ AST_EXT_LIB_CHECK([ICONV], [iconv], [iconv_open], [iconv.h])
+else
+ PBX_ICONV=1
+fi
AST_EXT_LIB_CHECK([IKSEMEL], [iksemel], [iks_start_sasl], [iksemel.h])