aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-02-15 00:59:21 +0000
committermmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-02-15 00:59:21 +0000
commit0142926ab096193d6af25a257545dab942b1f3c7 (patch)
tree5b984ef46f2cf7056419590cf7f942e8463c5359 /configure.ac
parentcd237a6e755ffad69cca5959fe9a4425f4f0517d (diff)
Same changes as made to 1.4 in revision 103710
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@103711 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 19 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 9f1287b0a..4838de4d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -648,8 +648,10 @@ fi
AST_EXT_LIB_CHECK([IKSEMEL], [iksemel], [iks_start_sasl], [iksemel.h])
if test "${USE_IMAP_TK}" != "no"; then
+ switch_to_system_on_failure="no"
if test "${IMAP_TK_DIR}" = ""; then
IMAP_TK_DIR=`pwd`"/../imap-2004g"
+ switch_to_system_on_failure="yes"
fi
saved_cppflags="${CPPFLAGS}"
saved_libs="${LIBS}"
@@ -776,18 +778,11 @@ if test "${USE_IMAP_TK}" != "no"; then
fi
CPPFLAGS="${saved_cppflags}"
LIBS="${saved_libs}"
- if test "${ac_cv_imap_tk}" = "yes"; then
- AC_MSG_RESULT(yes)
- IMAP_TK_LIB="${imap_libs} "`echo ${imap_ldflags}`
- IMAP_TK_INCLUDE="${imap_include}"
- PBX_IMAP_TK=1
- AC_DEFINE([HAVE_IMAP_TK], 1, [Define if your system has the UW IMAP Toolkit c-client library.])
- if test "${ac_cv_imap_tk2006}" = "yes"; then
- AC_DEFINE([HAVE_IMAP_TK2006], 1, [Define if your system has the UW IMAP Toolkit c-client library version 2006 or greater.])
- fi
- else
+ if test "${ac_cv_imap_tk}" = "no"; then
AC_MSG_RESULT(no)
- IMAP_TK_DIR="system"
+ if test "${switch_to_system_on_failure}" = "yes"; then
+ IMAP_TK_DIR="system"
+ fi
fi
fi
if test "${IMAP_TK_DIR}" = "system"; then
@@ -1034,20 +1029,20 @@ if test "${USE_IMAP_TK}" != "no"; then
)
fi
fi
- if test "${ac_cv_imap_tk}" = "yes"; then
- AC_MSG_RESULT(yes)
- CPPFLAGS="${saved_cppflags}"
- LIBS="${saved_libs}"
- IMAP_TK_LIB="${imap_libs} "`echo ${imap_ldflags}`
- IMAP_TK_INCLUDE="${imap_include}"
- PBX_IMAP_TK=1
- AC_DEFINE([HAVE_IMAP_TK], 1, [Define if your system has the UW IMAP Toolkit c-client library.])
- if test "${ac_cv_imap_tk2006}" = "yes"; then
- AC_DEFINE([HAVE_IMAP_TK2006], 1, [Define if your system has the UW IMAP Toolkit c-client library version 2006 or greater.])
- fi
- else
- AC_MSG_RESULT(no)
+ fi
+ if test "${ac_cv_imap_tk}" = "yes"; then
+ AC_MSG_RESULT(yes)
+ CPPFLAGS="${saved_cppflags}"
+ LIBS="${saved_libs}"
+ IMAP_TK_LIB="${imap_libs} "`echo ${imap_ldflags}`
+ IMAP_TK_INCLUDE="${imap_include}"
+ PBX_IMAP_TK=1
+ AC_DEFINE([HAVE_IMAP_TK], 1, [Define if your system has the UW IMAP Toolkit c-client library.])
+ if test "${ac_cv_imap_tk2006}" = "yes"; then
+ AC_DEFINE([HAVE_IMAP_TK2006], 1, [Define if your system has the UW IMAP Toolkit c-client library version 2006 or greater.])
fi
+ else
+ AC_MSG_RESULT(no)
fi
fi