aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2009-08-27 21:47:49 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2009-08-27 21:47:49 +0000
commitf54272619e038f8c0c8edbd578865bceda55572d (patch)
tree489ada988c596a9297ee730a905411e2c1f6a410 /configure.ac
parent91264d99e4ed946f9a8e8a1a1c894051cc20db2d (diff)
Merged revisions 214518 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ................ r214518 | tilghman | 2009-08-27 16:46:46 -0500 (Thu, 27 Aug 2009) | 14 lines Merged revisions 214517 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r214517 | tilghman | 2009-08-27 16:45:34 -0500 (Thu, 27 Aug 2009) | 7 lines Use autoconf to detect libcurl, as this enables cross-compilation checks, something we didn't allow before. (closes issue #15714) Reported by: pprindeville Patches: 20090813__issue15714.diff.txt uploaded by tilghman (license 14) Tested by: pprindeville ........ ................ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@214519 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 1 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 14b2e464c..f11a2cb89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1559,37 +1559,7 @@ AC_SUBST(PBX_GTK2)
AC_SUBST(GTK2_INCLUDE)
AC_SUBST(GTK2_LIB)
-if test "${USE_CURL}" != "no"; then
- AC_PATH_TOOL([CURL_CONFIG], [curl-config], No)
- if test ! x"${CURL_CONFIG}" = xNo; then
- # check for version
- if test $(printf "%d" 0x$(${CURL_CONFIG} --vernum)) -ge $(printf "%d" 0x070907); then
- CURL_INCLUDE=$(${CURL_CONFIG} --cflags)
- CURL_LIB=$(${CURL_CONFIG} --libs)
-
- AC_MSG_CHECKING(for curl_version() in curl/curl.h)
- saved_cppflags="${CPPFLAGS}"
- CPPFLAGS="${CPPFLAGS} ${CURL_INCLUDE}"
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <curl/curl.h>],
- [curl_version();])
- ],[
- AC_MSG_RESULT(yes)
- ac_cv_curl_h="yes"
- ],[
- AC_MSG_RESULT(no)
- ac_cv_curl_h="no"
- ]
- )
- CPPFLAGS="${saved_cppflags}"
- if test "${ac_cv_curl_h}" = "yes"; then
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- fi
- fi
-fi
+AST_LIBCURL_CHECK_CONFIG([], [7.10.1])
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts channels/h323/Makefile])
AST_CHECK_MANDATORY