aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-07-02 14:29:18 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-07-02 14:29:18 +0000
commit5ef82c39cc5d6fa4ef4ba38ea6579bb9501f4e9d (patch)
tree55e28879fe206ceeae989659ff739a7b63216472 /configure.ac
parent8a056288871c69090e70433c14b2ca507be459a7 (diff)
Merged revisions 126226,126513 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r126226 | seanbright | 2008-06-28 17:28:16 -0400 (Sat, 28 Jun 2008) | 8 lines Merge in changes from my cdr-tds-conversion branch. This changes the internal implementation from using the volatile libtds, to using the db-lib front end. The unintended side effect of this is that we support (at least) versions 0.62 through 0.82 of the FreeTDS distribution without any #ifdef ugliness. (closes issue #12844) Reported by: jcollie ........ r126513 | seanbright | 2008-06-30 07:57:42 -0400 (Mon, 30 Jun 2008) | 4 lines Cast a few more strings to char *, so that we can compile cleanly against FreeTDS 0.60. Update the docs to reflect that we can now compile and run against all modern releases of FreeTDS (0.60 through 0.82) ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@127397 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 1 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index d44384896..e33f6c314 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1380,34 +1380,7 @@ fi
AST_EXT_TOOL_CHECK([GMIME], [gmime])
-AST_EXT_LIB_CHECK([FREETDS], [tds], [tds_version], [tds.h])
-if test "${PBX_FREETDS}" != "0";
-then
- if test "${FREETDS_DIR}x" = "x";
- then
- for tds_dir in /usr /usr/local;
- do
- if test -f "${tds_dir}/include/tdsver.h";
- then
- FREETDS_DIR="${tds_dir}"
- fi
- done
- fi
- case `${GREP} TDS_VERSION_NO ${FREETDS_DIR:-/usr}/include/tdsver.h` in
- *0.64*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_64"
- ;;
- *0.63*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_63"
- ;;
- *0.62*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_62"
- ;;
- *)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_PRE_0_62"
- ;;
- esac
-fi
+AST_EXT_LIB_CHECK([FREETDS], [sybdb], [dbinit], [sybdb.h])
AST_EXT_LIB_CHECK([TERMCAP], [termcap], [tgetent], [])