aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-01 19:37:59 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-01 19:37:59 +0000
commit399778395040c809c7805cd678539fa8e4500bc8 (patch)
tree6d5a9eef20c02cf9420917da3379de99d344b8a6 /configure.ac
parentaf3fa0a75106a91bb3942d32c5e661d73a4f169f (diff)
Instead of adding the SOLARIS check to each HAVE_SYSINFO check let's just make the sysinfo autoconf logic a bit pickier about what it considers a usable sysinfo.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@77878 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c32eb54a2..cb6bc26b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,7 +382,7 @@ AC_SUBST(AST_DECLARATION_AFTER_STATEMENT)
AC_MSG_CHECKING(for sysinfo)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <sys/sysinfo.h>],
- [struct sysinfo sys_info;]),
+ [struct sysinfo sys_info; int uptime = sys_info.uptime]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_SYSINFO], 1, [Define to 1 if your system has sysinfo support]),
AC_MSG_RESULT(no)