aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-01-20 16:30:24 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-01-20 19:07:16 +0100
commita8ce061d86c3b6bd1f21655edf063a0c8c1a94f0 (patch)
treedb18d3e37565b70545d94c05b14876b689d5f471 /src/Makefile.am
parent2d845fca0c2e3561593e2255dbe7f53fdee9e144 (diff)
mtp: Move the link testing into a new file for mtp_link
The link testing should work under the linkset and if the SLTM is failing the link should be taken down and it should be restarted.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eb6ab11..defe121 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,17 +11,19 @@ mgcp_mgw_LDADD = $(LAFORGE_LIBS) $(NEXUSWARE_C7_LIBS) $(NEXUSWARE_UNIPORTE_LIBS)
cellmgr_ng_SOURCES = main.c mtp_layer3.c thread.c input/ipaccess.c pcap.c \
bss_patch.c bssap_sccp.c bsc_sccp.c bsc_ussd.c links.c \
- msc_conn.c link_udp.c snmp_mtp.c debug.c vty_interface.c isup.c
+ msc_conn.c link_udp.c snmp_mtp.c debug.c vty_interface.c isup.c \
+ mtp_link.c
cellmgr_ng_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS) $(NEXUSWARE_C7_LIBS) \
-lpthread -lnetsnmp -lcrypto
udt_relay_SOURCES = main_udt.c mtp_layer3.c thread.c input/ipaccess.c pcap.c \
msc_conn.c link_udp.c snmp_mtp.c debug.c vty_interface.c \
- bss_patch.c isup.c links.c sctp_m2ua.c
+ bss_patch.c isup.c links.c sctp_m2ua.c mtp_link.c
udt_relay_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS) $(NEXUSWARE_C7_LIBS) \
-lpthread -lnetsnmp -lcrypto -lm2ua -lsctp
osmo_stp_SOURCES = main_stp.c mtp_layer3.c thread.c pcap.c link_udp.c snmp_mtp.c \
- debug.c vty_interface.c links.c isup.c sctp_m2ua.c
+ debug.c vty_interface.c links.c isup.c sctp_m2ua.c \
+ mtp_link.c
osmo_stp_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOSCCP_LIBS) $(LIBOSMOVTY_LIBS) $(NEXUSWARE_C7_LIBS) \
-lpthread -lnetsnmp -lcrypto -lm2ua -lsctp