aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-07-28 03:32:52 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-07-28 03:36:32 +0800
commit97f66e2b534e2a54c63360a3f8134a0189c54e25 (patch)
tree903e34443767b09ef1d11575f8a1502f6295c7fd /configure.ac
Public release of the cellmgr_ng code to convert E1 to IPA SCCP
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..7ed1171
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script
+AC_INIT
+
+AM_INIT_AUTOMAKE(cellmgr_ng, 0.0.1)
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+dnl checks for header files
+AC_HEADER_STDC
+
+dnl Check for the SNMP header
+AC_CHECK_HEADERS([net-snmp/net-snmp-config.h])
+
+dnl Checks for typedefs, structures and compiler characteristics
+PKG_CHECK_MODULES([LAFORGE], [liblaf0rge1])
+PKG_CHECK_MODULES([SCCP], [libsccp])
+#PKG_CHECK_MODULES([NEXUSWARE_C7], [nexusware-c7])
+#PKG_CHECK_MODULES([NEXUSWARE_UNIPORTE], [nexusware-uniporte])
+
+AC_OUTPUT(
+ include/Makefile
+ include/mgcp/Makefile
+ include/openbsc_nat/Makefile
+ src/Makefile
+ tests/Makefile
+ tests/mtp/Makefile
+ tests/patching/Makefile
+ Makefile)