aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-09-15 20:35:58 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-09-15 20:40:23 +0800
commit615cf2f904c2cbe59da6b736fd342c8e551ee859 (patch)
tree6fcaddb2cc42964ff183658ef2a6164b83f7e542 /Makefile.am
parent5b084017017dc410897e6e4691d0bac10f0639c1 (diff)
Generate the version from the tag
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a3b4f6c..b3ec1f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,9 @@ AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
INCLUDES = $(all_includes) -I$(top_srcdir)/include
SUBDIRS = include src tests
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version