aboutsummaryrefslogtreecommitdiffstats
path: root/libasn1compiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libasn1compiler/Makefile.am')
-rw-r--r--libasn1compiler/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/libasn1compiler/Makefile.am b/libasn1compiler/Makefile.am
new file mode 100644
index 00000000..6b2babdf
--- /dev/null
+++ b/libasn1compiler/Makefile.am
@@ -0,0 +1,28 @@
+
+AM_CPPFLAGS = \
+ -I${top_srcdir}/libasn1parser \
+ -I${top_srcdir}/libasn1fix
+
+noinst_LTLIBRARIES = libasn1compiler.la
+
+libasn1compiler_la_LDFLAGS = -all-static
+libasn1compiler_la_SOURCES = \
+ asn1compiler.c asn1compiler.h \
+ asn1c_misc.c asn1c_misc.h \
+ asn1c_out.c asn1c_out.h \
+ asn1c_lang.c asn1c_lang.h \
+ asn1c_save.c asn1c_save.h \
+ asn1c_C.c asn1c_C.h \
+ asn1c_internal.h
+
+libasn1compiler_la_LIBADD = \
+ ${top_builddir}/libasn1parser/libasn1parser.la \
+ ${top_builddir}/libasn1fix/libasn1fix.la
+
+check_PROGRAMS = check_compiler
+
+TESTS = ${check_PROGRAMS}
+
+LDADD = ${noinst_LTLIBRARIES} ${libasn1compiler_la_LIBADD}
+DEPENDENCIES = ${LDADD}
+