aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLev Walkin <vlm@lionet.info>2016-03-14 05:14:07 -0700
committerLev Walkin <vlm@lionet.info>2016-03-14 05:14:07 -0700
commit64dd70cfc1cefbdddbdeb31c3d6014db841bda59 (patch)
treeb57fd43905d5c562b005509eb6fb4870c01ea3e6 /configure.ac
parentd60414d95722352fb33befdaa932f51454bb0a47 (diff)
EMIT_ASN_DEBUG is in skeletons flags
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cdf90814..ce85ebfb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AC_ARG_ENABLE([ASN_DEBUG],
[enable_asn_debug=$enableval], [enable_asn_debug=no])
AS_IF([test x$enable_asn_debug != xno], [
TESTSUITE_CFLAGS="-DEMIT_ASN_DEBUG"
+ SKELETONS_CFLAGS="-DEMIT_ASN_DEBUG"
])
AX_CHECK_COMPILE_FLAG([-Wall], [CFLAGS="$CFLAGS -Wall"])
@@ -79,7 +80,7 @@ AC_SUBST(TESTSUITE_CFLAGS)
dnl Skeletons should be very compatible with most of the compilers, hence
dnl very strict backward compatibility flags.
-SKELETONS_CFLAGS="${ADD_CFLAGS}"
+SKELETONS_CFLAGS="${ADD_CFLAGS} ${SKELETONS_CFLAGS}"
AX_CHECK_COMPILE_FLAG([-std=c89],
[SKELETONS_CFLAGS="$SKELETONS_CFLAGS -std=c89"])
AX_CHECK_COMPILE_FLAG([-Wpedantic],