aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLev Walkin <vlm@lionet.info>2014-09-17 00:32:03 -0700
committerLev Walkin <vlm@lionet.info>2014-09-17 00:32:03 -0700
commit58ecc7b4e33738295fc59baa4e1b4f2ca23cab5a (patch)
tree3662ec1b1d21c2363893004fce0d3297928e1806 /configure.ac
parent68e944500993f2780396b770a8b9d8660f528f7f (diff)
disable long debug output and implement --enable-ASN_DEBUG to restore old behavior
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f0031d8e..3d242c8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,13 @@ if test x$enable_werror = xyes; then
ADD_CFLAGS="-Werror -W -Wpointer-arith"
fi
+AC_ARG_ENABLE([ASN_DEBUG],
+ [ --enable-ASN_DEBUG produce debug log during `make check` testing],
+ enable_asn_debug=$enableval, enable_asn_debug=no)
+if test x$enable_asn_debug = xyes; then
+ TESTSUITE_CFLAGS="-DEMIT_ASN_DEBUG"
+fi
+
AX_CHECK_COMPILE_FLAG([-Wall], [CFLAGS="$CFLAGS -Wall"])
AX_CHECK_COMPILE_FLAG([-Wcast-qual], [CFLAGS="$CFLAGS -Wcast-qual"])
AX_CHECK_COMPILE_FLAG([-Wchar-subscripts],