aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLev Walkin <vlm@lionet.info>2016-01-24 22:13:27 -0800
committerLev Walkin <vlm@lionet.info>2016-01-24 22:13:27 -0800
commit104af19d65bc356c1e7df2d628e13ff8021bfb91 (patch)
treed5aa8b159cf8418e78b1ccc8e4e8f2bba421e5e3 /configure.ac
parent9736348c470b7641663009316fc8d94ba6a409c1 (diff)
pedantic c89 safety
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a937bf2b..a59ac43f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,9 +79,11 @@ dnl Skeletons should be very compatible with most of the compilers, hence
dnl very strict backward compatibility flags.
SKELETONS_CFLAGS="${ADD_CFLAGS}"
AX_CHECK_COMPILE_FLAG([-std=c89],
- [SKELETONS_FLAGS="$SKELETONS_FLAGS -std=c89"])
+ [SKELETONS_CFLAGS="$SKELETONS_CFLAGS -std=c89"])
AX_CHECK_COMPILE_FLAG([-Wpedantic],
- [SKELETONS_FLAGS="$SKELETONS_FLAGS -Wpedantic"])
+ [SKELETONS_CFLAGS="$SKELETONS_CFLAGS -Wpedantic"])
+AX_CHECK_COMPILE_FLAG([-Wno-duplicate-decl-specifier],
+ [SKELETONS_CFLAGS="$SKELETONS_CFLAGS -Wno-duplicate-decl-specifier"])
AC_SUBST(SKELETONS_CFLAGS)
dnl Checks for header files.