aboutsummaryrefslogtreecommitdiffstats
path: root/macosx-setup.sh
AgeCommit message (Expand)AuthorFilesLines
2017-06-22macosx-setup.sh: Skip downloading GMP if downloaded beforeAhmad Fatoum1-1/+1
2017-06-16Put the {un}install_XXX() definitions in the right order.Guy Harris1-163/+162
2017-06-16Move libgcrypt and libgpg-error to the set of required libraries.Guy Harris1-11/+8
2017-06-16Update to newer versions of libgcrypt and GnuTLS.Guy Harris1-42/+218
2017-04-29Don't add /usr/X11/lib/pkgconfig if we're not using GTK+.Guy Harris1-1/+3
2017-04-19macosx-setup.sh: Allow downloading packages without installationAhmad Fatoum1-2/+50
2017-04-19Add libxml2 as optional dependencyAhmad Fatoum1-0/+53
2017-04-13Update to GeoIP 1.6.10.Guy Harris1-7/+15
2017-04-05Update comments.Guy Harris1-15/+15
2017-04-05Follow HTTP redirects when fetching tarballs in macosx-setup.shAhmad Fatoum1-15/+15
2017-02-13Change Qt setup from 5.5.0 to 5.8.0Joerg Mayer1-1/+1
2017-02-13Make Libgcrypt a mandatory dependencyPeter Wu1-4/+8
2017-01-31Don't provide GTK setup by default.Joerg Mayer1-5/+6
2016-11-02Add snappy compression library setupJoerg Mayer1-0/+52
2016-11-02Add lz4 setup.Joerg Mayer1-0/+52
2016-10-30Update libssh to 0.7.3.Guy Harris1-18/+3
2016-10-20Support setting up sbc on macOS.Joerg Mayer1-0/+52
2016-10-17Fix typo in a messageJoerg Mayer1-1/+1
2016-10-13Remove nghttp2 code and use system' nghttp2Balint Reczey1-0/+53
2016-09-29macosx-setup: Upgrade c-ares to 1.12.0.Gerald Combs1-2/+2
2016-09-22Fix the "do we have Xcode?" test for older versions of Xcode.Guy Harris1-2/+4
2016-09-22Point people to the Mac App Store for Xcode.Guy Harris1-2/+2
2016-09-22Make it detect command-line-toos-only installations.Guy Harris1-8/+6
2016-09-22Don't mention a particular version of XQuartz.Guy Harris1-8/+3
2016-09-15Fix a test to work with Xcode 8.Guy Harris1-1/+9
2016-08-09Update to Lua 5.2.4.Guy Harris1-2/+2
2016-07-29Upgrade to libtool 2.4.6.Guy Harris1-1/+1
2016-03-30Install GNU autotools even on Snow Leopard.Guy Harris1-6/+5
2016-03-01HTTPS is now needed to download the pkg-config source.Guy Harris1-1/+1
2016-03-01Update the current XZ version.Guy Harris1-1/+1
2016-02-13Add support for libssh.Michael Tüxen1-0/+55
2016-01-02Update PNG_VERSION to the only version that actually exists.Joerg Mayer1-2/+2
2015-12-30Expand a comment.Guy Harris1-5/+5
2015-12-29CMake updatesJoerg Mayer1-3/+3
2015-12-29Allow overriding of the GTK and QT versions without modifying the script.Joerg Mayer1-8/+8
2015-10-14Build Lua with all the appropriate flags.Guy Harris1-1/+1
2015-10-11On 10.5, don't set GTK+ etc. versions if we haven't already set them.Guy Harris1-4/+16
2015-10-11Handle installing Qt 4.x.Guy Harris1-8/+26
2015-09-30It's "-Wno-XXX", not "-WnoXXX".Guy Harris1-1/+1
2015-09-30Another big hammer to shut Apple's deprecation squealing up.Guy Harris1-1/+4
2015-07-11Note the Qt bugs about the broken .pc files.Guy Harris1-1/+3
2015-07-11Update to Qt 5.5.0, to fix context menu issues.Guy Harris1-2/+7
2015-06-281.5.17 seems to be a typo. Change it to the probably intended 1.6.17Joerg Mayer1-1/+1
2015-06-26Disabling GTK by default in the official source was not intentionalJoerg Mayer1-1/+1
2015-06-26Make autotools install optional.Joerg Mayer1-17/+25
2015-06-24Add a bunch of " I missed in my previous patch.Joerg Mayer1-3/+3
2015-06-24Update build instructions for cmake near the end a bitJoerg Mayer1-3/+8
2015-06-24Handle downloading and installing CMake 3.x.Guy Harris1-15/+91
2015-04-17Download the Qt dmg and just do a binary installation.Guy Harris1-42/+39
2015-04-17Mount the CMake dmg we downloaded, don't download it again.Guy Harris1-1/+1