aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'wiretap/configure.in')
-rw-r--r--wiretap/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/wiretap/configure.in b/wiretap/configure.in
index 9a7bd9c7b3..a6628aac84 100644
--- a/wiretap/configure.in
+++ b/wiretap/configure.in
@@ -172,6 +172,12 @@ dnl Checks for header files
AC_HEADER_STDC
AC_CHECK_HEADERS(sys/time.h netinet/in.h unistd.h fcntl.h sys/stat.h sys/types.h)
+#
+# Define WS_VAR_IMPORT appropriately for declarations of external
+# variables exported from dynamically-linked libraries.
+#
+AC_DEFINE(WS_VAR_IMPORT, extern, [Define as the string to precede external variable declarations in dynamically-linked libraries])
+
# We must know our byte order
AC_C_BIGENDIAN