aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimaxmacphy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/wimaxmacphy/CMakeLists.txt')
-rw-r--r--plugins/wimaxmacphy/CMakeLists.txt43
1 files changed, 3 insertions, 40 deletions
diff --git a/plugins/wimaxmacphy/CMakeLists.txt b/plugins/wimaxmacphy/CMakeLists.txt
index 657dd1d380..996ada1649 100644
--- a/plugins/wimaxmacphy/CMakeLists.txt
+++ b/plugins/wimaxmacphy/CMakeLists.txt
@@ -19,29 +19,10 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-# Create the Windows .rc file for the plugin.
-# The values come from several files in the source, I can't see how to reuse them
+include(WiresharkPlugin)
# This info is from moduleinfo.nmake
-set(PACKAGE wimaxmacphy)
-set(MODULE_VERSION_MAJOR 0)
-set(MODULE_VERSION_MINOR 0)
-set(MODULE_VERSION_MICRO 1)
-set(MODULE_VERSION_EXTRA 0)
-set(MODULE_VERSION "${MODULE_VERSION_MAJOR}.${MODULE_VERSION_MINOR}.${MODULE_VERSION_MICRO}.${MODULE_VERSION_EXTRA}")
-set(RC_MODULE_VERSION "${MODULE_VERSION_MAJOR},${MODULE_VERSION_MINOR},${MODULE_VERSION_MICRO},${MODULE_VERSION_EXTRA}")
-
-# This info is from Makefile.common
-set(PLUGIN_NAME ${PACKAGE})
-
-# This info is from config.nmake
-set(MSVC_VARIANT "${CMAKE_GENERATOR}")
-
-# The rc.in requires a plain VERSION variable
-set(VERSION ${PROJECT_VERSION})
-
-# Create the plugin.rc file from the template
-configure_file(plugin.rc.in plugin.rc @ONLY)
+set_module_info(wimaxmacphy 0 0 1 0)
set(DISSECTOR_SRC
packet-wimaxmacphy.c
@@ -71,28 +52,10 @@ register_dissector_files(plugin.c
${DISSECTOR_SRC}
)
-add_library(wimaxmacphy ${LINK_MODE_MODULE}
- ${PLUGIN_FILES}
- ${CMAKE_CURRENT_BINARY_DIR}/plugin.rc
-)
-
-set_target_properties(wimaxmacphy PROPERTIES
- PREFIX ""
- LINK_FLAGS "${WS_LINK_FLAGS}"
- FOLDER "Plugins"
-)
-
-if(ENABLE_APPLICATION_BUNDLE)
- set_target_properties(wimaxmacphy PROPERTIES
- LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark
- )
-endif()
-
-target_link_libraries(wimaxmacphy epan)
+add_plugin_library(wimaxmacphy)
install(TARGETS wimaxmacphy
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)
-