aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/opcua/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/opcua/CMakeLists.txt')
-rw-r--r--plugins/opcua/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/opcua/CMakeLists.txt b/plugins/opcua/CMakeLists.txt
index bfc4ae0cee..9e529bd421 100644
--- a/plugins/opcua/CMakeLists.txt
+++ b/plugins/opcua/CMakeLists.txt
@@ -66,12 +66,13 @@ add_library(opcua ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(opcua PROPERTIES PREFIX "")
-#set_target_properties(opcua PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(opcua PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(opcua PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(opcua epan)
install(TARGETS opcua
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)