aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mate/Makefile.am')
-rw-r--r--plugins/mate/Makefile.am45
1 files changed, 41 insertions, 4 deletions
diff --git a/plugins/mate/Makefile.am b/plugins/mate/Makefile.am
index ec98924550..a3fa4c6042 100644
--- a/plugins/mate/Makefile.am
+++ b/plugins/mate/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for MATE Wireshark plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,51 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = mate
+
+#
+# Files generated by Flex.
+#
+FLEX_GENERATED_C_FILES = \
+ mate_parser.c
+
+FLEX_GENERATED_HEADER_FILES = \
+ mate_parser_lex.h
+
+#
+# Files generated by Lemon.
+#
+LEMON_GENERATED_C_FILES = \
+ mate_grammar.c
+
+LEMON_GENERATED_HEADER_FILES = \
+ mate_grammar.h
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-mate.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES) \
+ mate_setup.c \
+ mate_runtime.c \
+ mate_util.c
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ mate.h \
+ mate_util.h
+
+HEADER_FILES = \
+ $(FLEX_GENERATED_HEADER_FILES) \
+ $(CLEAN_HEADER_FILES)
+
#
# XXX - how to make this apply only to clean files?
#
@@ -71,7 +109,6 @@ MAINTAINERCLEANFILES = \
EXTRA_DIST = \
mate_grammar.lemon \
mate_parser.l \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt \
examples/call.mate \