aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mate/CMakeLists.txt')
-rw-r--r--plugins/mate/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/mate/CMakeLists.txt b/plugins/mate/CMakeLists.txt
index b3c61022df..e780c7da01 100644
--- a/plugins/mate/CMakeLists.txt
+++ b/plugins/mate/CMakeLists.txt
@@ -74,12 +74,13 @@ add_library(mate ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(mate PROPERTIES PREFIX "")
-#set_target_properties(mate PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(mate PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(mate PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(mate epan)
install(TARGETS mate
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)