aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mate/CMakeLists.txt')
-rw-r--r--plugins/mate/CMakeLists.txt26
1 files changed, 25 insertions, 1 deletions
diff --git a/plugins/mate/CMakeLists.txt b/plugins/mate/CMakeLists.txt
index e4dc6fe3b9..6372e54d1b 100644
--- a/plugins/mate/CMakeLists.txt
+++ b/plugins/mate/CMakeLists.txt
@@ -19,6 +19,30 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+# Create the Windows .rc file for the plugin.
+# The values come from several files in the source, I can't see how to reuse them
+
+# This info is from moduleinfo.nmake
+set(PACKAGE mate)
+set(MODULE_VERSION_MAJOR 1)
+set(MODULE_VERSION_MINOR 0)
+set(MODULE_VERSION_MICRO 0)
+set(MODULE_VERSION_EXTRA 1)
+set(MODULE_VERSION "${MODULE_VERSION_MAJOR}.${MODULE_VERSION_MINOR}.${MODULE_VERSION_MICRO}.${MODULE_VERSION_EXTRA}")
+set(RC_MODULE_VERSION "${MODULE_VERSION_MAJOR},${MODULE_VERSION_MINOR},${MODULE_VERSION_MICRO},${MODULE_VERSION_EXTRA}")
+
+# This info is from Makefile.common
+set(PLUGIN_NAME ${PACKAGE})
+
+# This info is from config.nmake
+set(MSVC_VARIANT "${CMAKE_GENERATOR}")
+
+# The rc.in requires a plain VERSION variable
+set(VERSION ${PROJECT_VERSION})
+
+# Create the plugin.rc file from the template
+configure_file(plugin.rc.in plugin.rc @ONLY)
+
set(DISSECTOR_SRC
packet-mate.c
)
@@ -70,7 +94,7 @@ register_dissector_files(plugin.c
add_library(mate ${LINK_MODE_MODULE}
${PLUGIN_FILES}
- plugin.rc
+ ${CMAKE_CURRENT_BINARY_DIR}/plugin.rc
)
set_target_properties(mate PROPERTIES