aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/m2m/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/m2m/CMakeLists.txt')
-rw-r--r--plugins/m2m/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/m2m/CMakeLists.txt b/plugins/m2m/CMakeLists.txt
index 9878043c31..a067cfde43 100644
--- a/plugins/m2m/CMakeLists.txt
+++ b/plugins/m2m/CMakeLists.txt
@@ -58,12 +58,13 @@ add_library(m2m ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(m2m PROPERTIES PREFIX "")
-#set_target_properties(m2m PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(m2m PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(m2m PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(m2m epan)
install(TARGETS m2m
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)