aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/irda/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/irda/CMakeLists.txt')
-rw-r--r--plugins/irda/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/irda/CMakeLists.txt b/plugins/irda/CMakeLists.txt
index 88aa656c6c..f99f7cd5c6 100644
--- a/plugins/irda/CMakeLists.txt
+++ b/plugins/irda/CMakeLists.txt
@@ -55,12 +55,13 @@ add_library(irda ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(irda PROPERTIES PREFIX "")
-#set_target_properties(irda PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(irda PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(irda PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(irda epan)
install(TARGETS irda
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)