aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/giop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/giop/CMakeLists.txt')
-rw-r--r--plugins/giop/CMakeLists.txt20
1 files changed, 12 insertions, 8 deletions
diff --git a/plugins/giop/CMakeLists.txt b/plugins/giop/CMakeLists.txt
index cc383af6f9..793ae621ed 100644
--- a/plugins/giop/CMakeLists.txt
+++ b/plugins/giop/CMakeLists.txt
@@ -57,12 +57,13 @@ add_library(cosnaming ${LINK_MODE_MODULE}
${COSNAMING_SRC}
)
set_target_properties(cosnaming PROPERTIES PREFIX "")
-#set_target_properties(cosnaming PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(cosnaming PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(cosnaming PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(cosnaming epan)
install(TARGETS cosnaming
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)
@@ -71,12 +72,13 @@ add_library(coseventcomm ${LINK_MODE_MODULE}
${COSEVENTCOMM_SRC}
)
set_target_properties(coseventcomm PROPERTIES PREFIX "")
-#set_target_properties(coseventcomm PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(coseventcomm PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(coseventcomm PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(coseventcomm epan)
install(TARGETS coseventcomm
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)
@@ -85,12 +87,13 @@ add_library(tango ${LINK_MODE_MODULE}
${TANGO_SRC}
)
set_target_properties(tango PROPERTIES PREFIX "")
-#set_target_properties(tango PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(tango PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(tango PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(tango epan)
install(TARGETS tango
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)
@@ -99,12 +102,13 @@ add_library(parlay ${LINK_MODE_MODULE}
${PARLAY_SRC}
)
set_target_properties(parlay PROPERTIES PREFIX "")
-#set_target_properties(parlay PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(parlay PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(parlay PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(parlay epan)
install(TARGETS parlay
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)