aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/ethercat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ethercat/Makefile.am')
-rw-r--r--plugins/ethercat/Makefile.am33
1 files changed, 29 insertions, 4 deletions
diff --git a/plugins/ethercat/Makefile.am b/plugins/ethercat/Makefile.am
index ef85f4189d..c1bedc99e8 100644
--- a/plugins/ethercat/Makefile.am
+++ b/plugins/ethercat/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for EtherCAT plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,39 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = ethercat
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-ams.c \
+ packet-ecatmb.c \
+ packet-esl.c \
+ packet-ethercat-datagram.c \
+ packet-ethercat-frame.c \
+ packet-ioraw.c \
+ packet-nv.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ packet-ams.h \
+ packet-ecatmb.h \
+ packet-ethercat-datagram.h \
+ packet-ethercat-frame.h \
+ packet-ioraw.h \
+ packet-nv.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = ethercat.la
ethercat_la_SOURCES = \
@@ -47,6 +73,5 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt