aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/epan/wimaxasncp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/epan/wimaxasncp/CMakeLists.txt')
-rw-r--r--plugins/epan/wimaxasncp/CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/plugins/epan/wimaxasncp/CMakeLists.txt b/plugins/epan/wimaxasncp/CMakeLists.txt
index 3698520775..f56f127be1 100644
--- a/plugins/epan/wimaxasncp/CMakeLists.txt
+++ b/plugins/epan/wimaxasncp/CMakeLists.txt
@@ -33,21 +33,16 @@ set(PLUGIN_FILES
${DISSECTOR_SRC}
)
-set(CLEAN_FILES
- ${PLUGIN_FILES}
+add_lex_files(LEX_FILES PLUGIN_FILES
+ wimaxasncp_dict.l
)
set_source_files_properties(
- ${CLEAN_FILES}
+ ${PLUGIN_FILES}
PROPERTIES
COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
)
-add_lex_files(LEX_FILES GENERATED_FILES
- wimaxasncp_dict.l
-)
-list(APPEND PLUGIN_FILES ${GENERATED_FILES})
-
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
register_plugin_files(plugin.c