aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/epan/gryphon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/epan/gryphon/Makefile.am')
-rw-r--r--plugins/epan/gryphon/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/plugins/epan/gryphon/Makefile.am b/plugins/epan/gryphon/Makefile.am
new file mode 100644
index 0000000000..81495fdd7c
--- /dev/null
+++ b/plugins/epan/gryphon/Makefile.am
@@ -0,0 +1,66 @@
+# Makefile.am
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include $(top_srcdir)/Makefile.am.inc
+include $(top_srcdir)/plugins/Makefile.am.inc
+
+# the name of the plugin
+PLUGIN_NAME = gryphon
+
+PLUGIN_VERSION = 0.0.4
+
+BUILT_SOURCES = \
+ plugin.c
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-gryphon.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ packet-gryphon.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
+epan_plugin_LTLIBRARIES = gryphon.la
+
+gryphon_la_SOURCES = \
+ $(SRC_FILES) \
+ $(HEADER_FILES)
+
+nodist_gryphon_la_SOURCES = \
+ plugin.c
+
+gryphon_la_CPPFLAGS = $(AM_CPPFLAGS) $(PLUGIN_CPPFLAGS)
+
+gryphon_la_CFLAGS = $(AM_CFLAGS) $(PLUGIN_CFLAGS)
+
+gryphon_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+
+DISTCLEANFILES = \
+ plugin.c
+
+EXTRA_DIST = \
+ CMakeLists.txt