aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wmem/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/wmem/Makefile.am')
-rw-r--r--epan/wmem/Makefile.am54
1 files changed, 44 insertions, 10 deletions
diff --git a/epan/wmem/Makefile.am b/epan/wmem/Makefile.am
index 99f519af83..6fa68a6fa8 100644
--- a/epan/wmem/Makefile.am
+++ b/epan/wmem/Makefile.am
@@ -19,7 +19,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(LIBWMEM_CFLAGS) \
@@ -29,12 +28,52 @@ noinst_LTLIBRARIES = libwmem.la
EXTRA_PROGRAMS = wmem_test
+libwmem_la_SOURCES = \
+ wmem_array.c \
+ wmem_core.c \
+ wmem_allocator_block.c \
+ wmem_allocator_block_fast.c \
+ wmem_allocator_simple.c \
+ wmem_allocator_strict.c \
+ wmem_list.c \
+ wmem_map.c \
+ wmem_miscutl.c \
+ wmem_scopes.c \
+ wmem_stack.c \
+ wmem_strbuf.c \
+ wmem_strutl.c \
+ wmem_tree.c \
+ wmem_interval_tree.c \
+ wmem_user_cb.c \
+ wmem.h \
+ wmem_array.h \
+ wmem_core.h \
+ wmem_allocator.h \
+ wmem_allocator_block.h \
+ wmem_allocator_block_fast.h \
+ wmem_allocator_simple.h \
+ wmem_allocator_strict.h \
+ wmem_list.h \
+ wmem_map.h \
+ wmem_map_int.h \
+ wmem_miscutl.h \
+ wmem_queue.h \
+ wmem_scopes.h \
+ wmem_stack.h \
+ wmem_strbuf.h \
+ wmem_strutl.h \
+ wmem_tree.h \
+ wmem_tree-int.h \
+ wmem_interval_tree.h \
+ wmem_user_cb.h \
+ wmem_user_cb_int.h
+
+wmem_test_SOURCES = wmem_test.c
+
wmem_test_LDADD = \
libwmem.la \
$(GLIB_LIBS)
-test-programs: wmem_test
-
CLEANFILES = \
libwmem.a \
libwmem.la \
@@ -42,21 +81,16 @@ CLEANFILES = \
DISTCLEANFILES =
-MAINTAINERCLEANFILES = \
+MAINTAINERCLEANFILES = \
Makefile.in
-libwmem_la_SOURCES = \
- $(LIBWMEM_SRC) \
- $(LIBWMEM_INCLUDES)
-
EXTRA_DIST = \
- Makefile.common \
CMakeLists.txt
checkapi:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g termoutput -build \
-sourcedir=$(srcdir) \
- $(LIBWMEM_SRC)
+ $(libwmem_la_SOURCES)
#
# Editor modelines - https://www.wireshark.org/tools/modelines.html