aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/ros/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/ros/Makefile.am')
-rw-r--r--epan/dissectors/asn1/ros/Makefile.am40
1 files changed, 37 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/ros/Makefile.am b/epan/dissectors/asn1/ros/Makefile.am
index 11932c53a4..0a9536e202 100644
--- a/epan/dissectors/asn1/ros/Makefile.am
+++ b/epan/dissectors/asn1/ros/Makefile.am
@@ -16,7 +16,41 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME=ros
+
+EXPORT_FILES = $(PROTOCOL_NAME)-exp.cnf
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ $(PROTOCOL_NAME).asn \
+ Remote-Operations-Information-Objects.asn
+
+INCLUDED_ASN_FILE_LIST = \
+ Remote-Operations-Generic-ROS-PDUs.asn \
+ Remote-Operations-Information-Objects.asn \
+ Remote-Operations-Useful-Definitions.asn \
+ ros-err.cnf \
+ ros-inv.cnf \
+ ros-rej.cnf \
+ ros-res.cnf
+
+# The packet-$(PROTOCOL_NAME)-template.h and $(PROTOCOL_NAME).asn
+# files do not exist # for all protocols: Please add/remove as required.
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ $(INCLUDED_ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ packet-$(PROTOCOL_NAME)-template.h \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS= -b
+
+EXTRA_CNF=