aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/q932/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/q932/Makefile.am')
-rw-r--r--epan/dissectors/asn1/q932/Makefile.am32
1 files changed, 29 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/q932/Makefile.am b/epan/dissectors/asn1/q932/Makefile.am
index 11932c53a4..3c01c57071 100644
--- a/epan/dissectors/asn1/q932/Makefile.am
+++ b/epan/dissectors/asn1/q932/Makefile.am
@@ -16,7 +16,33 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME = q932
+
+EXPORT_FILES = $(PROTOCOL_NAME)-exp.cnf
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ Addressing-Data-Elements.asn \
+ Network-Facility-Extension.asn \
+ Network-Protocol-Profile-component.asn \
+ Interpretation-component.asn
+
+# The packet-$(PROTOCOL_NAME)-template.h and $(PROTOCOL_NAME).asn
+# files do not exist for all protocols: Please add/remove as required.
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ packet-$(PROTOCOL_NAME)-template.h \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS= -b
+
+EXTRA_CNF =