aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/pcap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/pcap/Makefile.am')
-rw-r--r--epan/dissectors/asn1/pcap/Makefile.am29
1 files changed, 26 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/pcap/Makefile.am b/epan/dissectors/asn1/pcap/Makefile.am
index 11932c53a4..912900326b 100644
--- a/epan/dissectors/asn1/pcap/Makefile.am
+++ b/epan/dissectors/asn1/pcap/Makefile.am
@@ -16,7 +16,30 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME = pcap
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ PCAP-CommonDataTypes.asn \
+ PCAP-Constants.asn \
+ PCAP-Containers.asn \
+ PCAP-IEs.asn \
+ PCAP-PDU-Contents.asn \
+ PCAP-PDU-Descriptions.asn
+
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS =
+
+EXTRA_CNF =