aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/p7/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/p7/Makefile.am')
-rw-r--r--epan/dissectors/asn1/p7/Makefile.am48
1 files changed, 45 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/p7/Makefile.am b/epan/dissectors/asn1/p7/Makefile.am
index 11932c53a4..6b45925bb8 100644
--- a/epan/dissectors/asn1/p7/Makefile.am
+++ b/epan/dissectors/asn1/p7/Makefile.am
@@ -16,7 +16,49 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME=p7
+
+EXPORT_FILES = \
+ $(PROTOCOL_NAME)-exp.cnf
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ MSAbstractService.asn \
+ MSGeneralAttributeTypes.asn \
+ MSAccessProtocol.asn \
+ MSUpperBounds.asn
+
+# The packet-$(PROTOCOL_NAME)-template.h and $(PROTOCOL_NAME).asn
+# files do not exist for all protocols: Please add/remove as required.
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ packet-$(PROTOCOL_NAME)-template.h \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS = -b -L -C
+
+EXTRA_CNF = \
+ $(builddir)/../p1/p1-exp.cnf \
+ $(builddir)/../ros/ros-exp.cnf \
+ $(builddir)/../rtse/rtse.cnf
+
+EXPORT_DEPENDS = \
+ $(builddir)/../p1/p1-exp.cnf
+
+$(builddir)/../p1/p1-exp.cnf:
+ (cd $(builddir)/../p1 && $(MAKE_CNF_EXPORT))
+
+$(builddir)/../ros/ros-exp.cnf:
+ (cd $(builddir)/../ros && $(MAKE_CNF_EXPORT))
+
+$(builddir)/../rtse/rtse-exp.cnf:
+ (cd $(builddir)/../rtse && $(MAKE_CNF_EXPORT))