aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/lcsap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/lcsap/Makefile.am')
-rw-r--r--epan/dissectors/asn1/lcsap/Makefile.am40
1 files changed, 37 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/lcsap/Makefile.am b/epan/dissectors/asn1/lcsap/Makefile.am
index 11932c53a4..2ef977ade1 100644
--- a/epan/dissectors/asn1/lcsap/Makefile.am
+++ b/epan/dissectors/asn1/lcsap/Makefile.am
@@ -16,7 +16,41 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME=lcsap
+
+#DISSECTOR_FILES=packet-$(PROTOCOL_NAME).c
+
+EXPORT_FILES = $(PROTOCOL_NAME)-exp.cnf
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ LCS-AP-CommonDataTypes.asn\
+ LCS-AP-Constants.asn\
+ LCS-AP-Containers.asn\
+ LCS-AP-IEs.asn\
+ LCS-AP-PDU-Contents.asn\
+ LCS-AP-PDU-Descriptions.asn
+
+# The packet-$(PROTOCOL_NAME)-template.h and $(PROTOCOL_NAME).asn
+# files do not exist for all protocols: Please add/remove as required.
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ packet-$(PROTOCOL_NAME)-template.h \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS=
+
+EXTRA_CNF= \
+ $(builddir)/../x509if/x509if-exp.cnf
+
+$(builddir)/../x509if/x509if-exp.cnf:
+ (cd ../x509if && $(MAKE_CNF_EXPORT))