aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/kerberos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/kerberos/Makefile.am')
-rw-r--r--epan/dissectors/asn1/kerberos/Makefile.am30
1 files changed, 27 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/kerberos/Makefile.am b/epan/dissectors/asn1/kerberos/Makefile.am
index 11932c53a4..ff7b2558e0 100644
--- a/epan/dissectors/asn1/kerberos/Makefile.am
+++ b/epan/dissectors/asn1/kerberos/Makefile.am
@@ -16,7 +16,31 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME=kerberos
+
+EXPORT_FILES = \
+ $(PROTOCOL_NAME)-exp.cnf
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ KerberosV5Spec2.asn \
+ k5.asn \
+ RFC3244.asn
+
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ packet-$(PROTOCOL_NAME)-template.h \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS= -b
+
+EXTRA_CNF=