aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dfilter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dfilter/Makefile.am')
-rw-r--r--epan/dfilter/Makefile.am117
1 files changed, 94 insertions, 23 deletions
diff --git a/epan/dfilter/Makefile.am b/epan/dfilter/Makefile.am
index 81703011f4..d74af56551 100644
--- a/epan/dfilter/Makefile.am
+++ b/epan/dfilter/Makefile.am
@@ -19,7 +19,6 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) -I$(top_srcdir)/epan -I$(lemon_srcdir) \
@@ -27,30 +26,88 @@ AM_CPPFLAGS = $(INCLUDEDIRS) -I$(top_srcdir)/epan -I$(lemon_srcdir) \
noinst_LTLIBRARIES = libdfilter_generated.la libdfilter.la
-CLEANFILES = \
- libdfilter.a \
- libdfilter.la \
- libdfilter_generated.a \
- libdfilter_generated.la \
- *~
-
-DISTCLEANFILES = \
- grammar.out \
- $(NODIST_GENERATED_FILES)
+# C source files that are part of the display filter source; this includes only
+# .c files, not YACC or Lex or... files (as Makefile.nmake maps this list
+# into a list of object files by replacing ".c" with ".obj") or files
+# generated from YACC or Lex files (as Automake doesn't want them in
+# _SOURCES variables).
+NONGENERATED_C_FILES = \
+ dfilter.c \
+ dfilter-macro.c \
+ dfunctions.c \
+ dfvm.c \
+ drange.c \
+ gencode.c \
+ semcheck.c \
+ sttype-function.c \
+ sttype-integer.c \
+ sttype-pointer.c \
+ sttype-range.c \
+ sttype-set.c \
+ sttype-string.c \
+ sttype-test.c \
+ syntax-tree.c
+
+# Header files that are not generated from other files
+NONGENERATED_HEADER_FILES = \
+ dfilter.h \
+ dfilter-macro.h \
+ dfilter-int.h \
+ dfunctions.h \
+ dfvm.h \
+ drange.h \
+ gencode.h \
+ semcheck.h \
+ sttype-function.h \
+ sttype-range.h \
+ sttype-set.h \
+ sttype-test.h \
+ syntax-tree.h
+
+# Files that generate compileable files
+GENERATOR_FILES = \
+ grammar.lemon \
+ scanner.l
+
+# The C source files they generate and that we want in the distribution
+GENERATED_C_FILES = \
+ scanner.c
+
+# The C source files they generate and that we don't want in the distribution
+NODIST_GENERATED_C_FILES = \
+ grammar.c
+
+# The header files that they generate and that we want in the distribution
+GENERATED_HEADER_FILES = \
+ scanner_lex.h
+
+# The header files that they generate and that we don't want in the distribution
+NODIST_GENERATED_HEADER_FILES = \
+ grammar.h
-MAINTAINERCLEANFILES = \
- $(GENERATED_FILES) \
- $(NODIST_GENERATED_FILES) \
- Makefile.in
+# All the generated files we want in the distribution.
+GENERATED_FILES = \
+ $(GENERATED_C_FILES) \
+ $(GENERATED_HEADER_FILES)
-BUILT_SOURCES = \
- grammar.h
+# All the generated files we don't want in the distribution.
+NODIST_GENERATED_FILES = \
+ $(NODIST_GENERATED_C_FILES) \
+ $(NODIST_GENERATED_HEADER_FILES)
#Since code generated by lex may trigger gcc warnings, we are now generating two
#libraries. A single library is generated with the lex code without the barrier
#"stop on warning". An other library is generated from the remaining source
#files with the "stop on warning" barrier.
-libdfilter_la_SOURCES = $(NONGENERATED_C_FILES) $(NONGENERATED_HEADER_FILES)
+libdfilter_la_SOURCES = \
+ $(NONGENERATED_C_FILES) \
+ $(NONGENERATED_HEADER_FILES)
+
+libdfilter_la_LIBADD = \
+ libdfilter_generated.la
+
+libdfilter_la_DEPENDENCIES = \
+ libdfilter_generated.la
libdfilter_generated_la_SOURCES = \
$(GENERATED_C_FILES) \
@@ -62,16 +119,30 @@ nodist_libdfilter_generated_la_SOURCES = \
$(NODIST_GENERATED_C_FILES) \
$(NODIST_GENERATED_HEADER_FILES)
-libdfilter_la_LIBADD = libdfilter_generated.la
-
-libdfilter_la_DEPENDENCIES = libdfilter_generated.la
-
EXTRA_DIST = \
.editorconfig \
$(GENERATOR_FILES) \
- Makefile.common \
CMakeLists.txt
+CLEANFILES = \
+ libdfilter.a \
+ libdfilter.la \
+ libdfilter_generated.a \
+ libdfilter_generated.la \
+ *~
+
+DISTCLEANFILES = \
+ grammar.out \
+ $(NODIST_GENERATED_FILES)
+
+MAINTAINERCLEANFILES = \
+ $(GENERATED_FILES) \
+ $(NODIST_GENERATED_FILES) \
+ Makefile.in
+
+BUILT_SOURCES = \
+ grammar.h
+
scanner_lex.h : scanner.c
grammar.h : grammar.c