aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 23e63d1340..88a14ba9fb 100644
--- a/configure.in
+++ b/configure.in
@@ -468,6 +468,24 @@ else
])
fi
+AC_CHECK_FUNC(strtoull,,
+ [
+ #
+ # No strtoull - do we have strtouq?
+ #
+ AC_CHECK_FUNC(strtouq,
+ [
+ #
+ # Yes - define strtoull to be strtouq.
+ #
+ AC_DEFINE(strtoull, strtouq,
+ [Define as a function that behaves like strtoull])
+ ],
+ [
+ AC_MSG_ERROR([This platform has neither strtoull nor strtouq.])
+ ])
+ ])
+
AC_SUBST(ethereal_bin)
AC_SUBST(ethereal_man)