aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 1 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 7346d73744..2d32b878d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -459,22 +459,7 @@ AS_IF([test $have_a2x_text = lynx], [A2X_LYNX="--lynx"])
AC_SUBST(A2X_LYNX)
# RPM
-#
-# Looks for the rpmbuild program, and checks to see if we can redefine "_topdir".
-#
-AC_CHECK_PROGS(RPMBUILD, [rpmbuild], [false])
-if test "x$RPMBUILD" != "xfalse" ; then
- AC_MSG_CHECKING([to see if we can redefine _topdir])
- rpm --define '_topdir /tmp' > /dev/null 2>&1
- if test $? -eq 0 ; then
- AC_MSG_RESULT(yes)
- have_rpm=yes
- else
- AC_MSG_RESULT([no, you'll have to build packages manually])
- have_rpm=no
- fi
-fi
-AM_CONDITIONAL(HAVE_RPM, [test "x$have_rpm" = xyes])
+AC_CHECK_PROGS(RPMBUILD, [rpmbuild], [rpmbuild])
#
# Use this as a proxy for "is this macOS" (just in case somebody actually