aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
index 2f446f6648..ce6ca048fb 100644
--- a/codecs/CMakeLists.txt
+++ b/codecs/CMakeLists.txt
@@ -49,6 +49,11 @@ if(HAVE_BCG729)
list(APPEND wscodecs_LIBS ${BCG729_LIBRARIES})
endif()
+if(AMRNB_FOUND)
+ list(APPEND WSCODECS_FILES amr/amrdecode.c)
+ list(APPEND wscodecs_LIBS ${AMRNB_LIBRARIES})
+endif()
+
add_library(wscodecs
${WSCODECS_FILES}
${CMAKE_BINARY_DIR}/image/libwscodecs.rc