aboutsummaryrefslogtreecommitdiffstats
path: root/caputils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'caputils/Makefile.am')
-rw-r--r--caputils/Makefile.am52
1 files changed, 25 insertions, 27 deletions
diff --git a/caputils/Makefile.am b/caputils/Makefile.am
index 043ad29ff4..ebd311aaf6 100644
--- a/caputils/Makefile.am
+++ b/caputils/Makefile.am
@@ -19,19 +19,35 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS) $(LIBNL_CFLAGS)
noinst_LIBRARIES = libcaputils.a
-PLATFORM_CAPUTILS_SRC = \
- capture-pcap-util-unix.c
+# All sources that should be put in the source distribution tarball
+libcaputils_a_SOURCES = \
+ capture_ifinfo.h \
+ capture-pcap-util.h \
+ capture-pcap-util.c \
+ capture-pcap-util-unix.c \
+ capture-pcap-util-int.h \
+ capture-wpcap.h \
+ capture_wpcap_packet.h \
+ iface_monitor.c \
+ iface_monitor.h \
+ ws80211_utils.c \
+ ws80211_utils.h
+
+#
+# This is used to build dumpcap, and dumpcap is, if possible, built as
+# a position-independent executable (for address space layout randomization,
+# as it might be running with extra privileges), so this library needs
+# to be built that way as well.
+#
+libcaputils_a_CFLAGS = $(AM_CFLAGS) $(PIE_CFLAGS)
-CAPUTILS_SRC = \
- $(COMMON_CAPUTILS_SRC) \
- $(PLATFORM_CAPUTILS_SRC)
+libcaputils_a_DEPENDENCIES =
CLEANFILES = \
doxygen-caputils.tag \
@@ -39,12 +55,10 @@ CLEANFILES = \
*~
MAINTAINERCLEANFILES = \
- $(GENERATED_FILES) \
Makefile.in
EXTRA_DIST = \
.editorconfig \
- $(GENERATOR_FILES) \
airpcap.h \
airpcap_loader.c \
airpcap_loader.h \
@@ -55,23 +69,7 @@ EXTRA_DIST = \
capture_wpcap_packet.c \
capture_wpcap_packet.h \
CMakeLists.txt \
- doxygen.cfg.in \
- Makefile.common
-
-# All sources that should be put in the source distribution tarball
-libcaputils_a_SOURCES = \
- $(CAPUTILS_SRC) \
- $(noinst_HEADERS)
-
-#
-# This is used to build dumpcap, and dumpcap is, if possible, built as
-# a position-independent executable (for address space layout randomization,
-# as it might be running with extra privileges), so this library needs
-# to be built that way as well.
-#
-libcaputils_a_CFLAGS = $(AM_CFLAGS) $(PIE_CFLAGS)
-
-libcaputils_a_DEPENDENCIES =
+ doxygen.cfg.in
doxygen:
if HAVE_DOXYGEN
@@ -88,9 +86,9 @@ checkapi: checkapi-base checkapi-todo
checkapi-base:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
-sourcedir=$(srcdir) \
- $(CAPUTILS_SRC)
+ $(libcaputils_a_SOURCES)
checkapi-todo:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
-sourcedir=$(srcdir) \
- $(CAPUTILS_SRC)
+ $(libcaputils_a_SOURCES)