aboutsummaryrefslogtreecommitdiffstats
path: root/capchild/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capchild/Makefile.am')
-rw-r--r--capchild/Makefile.am64
1 files changed, 0 insertions, 64 deletions
diff --git a/capchild/Makefile.am b/capchild/Makefile.am
deleted file mode 100644
index 981c797e05..0000000000
--- a/capchild/Makefile.am
+++ /dev/null
@@ -1,64 +0,0 @@
-# Makefile.am
-# Automake file for the "talking to dumpcap" routines for Wireshark
-#
-# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@wireshark.org>
-# Copyright 1998 Gerald Combs
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include $(top_srcdir)/Makefile.am.inc
-
-AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS) $(PCAP_CFLAGS)
-
-noinst_LIBRARIES = libcapchild.a
-
-# All sources that should be put in the source distribution tarball
-libcapchild_a_SOURCES = \
- capture_ifinfo.c \
- capture_sync.c \
- capture_session.h \
- capture_sync.h
-
-libcapchild_a_DEPENDENCIES =
-
-EXTRA_DIST = \
- CMakeLists.txt \
- doxygen.cfg.in
-
-CLEANFILES = \
- doxygen-capchild.tag
-
-doxygen:
-if HAVE_DOXYGEN
- $(DOXYGEN) doxygen.cfg
-endif # HAVE_DOXYGEN
-
-wsar_html: doxygen.cfg ../doxygen_global.cfg
-if HAVE_DOXYGEN
- (umask 022 ; $(DOXYGEN) doxygen.cfg)
-endif
-
-checkapi: checkapi-base checkapi-todo
-
-checkapi-base:
- $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
- -sourcedir=$(srcdir) \
- $(libcapchild_a_SOURCES)
-
-checkapi-todo:
- $(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
- -sourcedir=$(srcdir) \
- $(libcapchild_a_SOURCES)