aboutsummaryrefslogtreecommitdiffstats
path: root/capchild/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capchild/Makefile.am')
-rw-r--r--capchild/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/capchild/Makefile.am b/capchild/Makefile.am
index 74d49969ff..5a50b68eea 100644
--- a/capchild/Makefile.am
+++ b/capchild/Makefile.am
@@ -19,29 +19,33 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
noinst_LIBRARIES = libcapchild.a
+# All sources that should be put in the source distribution tarball
+libcapchild_a_SOURCES = \
+ capture_ifinfo.c \
+ capture_sync.c \
+ capture_session.h \
+ capture_sync.h
+
+libcapchild_a_DEPENDENCIES =
+
+EXTRA_DIST = \
+ CMakeLists.txt \
+ doxygen.cfg.in
+
CLEANFILES = \
doxygen-capchild.tag \
libcapchild.a \
*~
MAINTAINERCLEANFILES = \
- $(GENERATED_FILES) \
Makefile.in
-# All sources that should be put in the source distribution tarball
-libcapchild_a_SOURCES = \
- $(CAPCHILD_SRC) \
- $(noinst_HEADERS)
-
-libcapchild_a_DEPENDENCIES =
-
doxygen:
if HAVE_DOXYGEN
$(DOXYGEN) doxygen.cfg
@@ -57,15 +61,9 @@ checkapi: checkapi-base checkapi-todo
checkapi-base:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
-sourcedir=$(srcdir) \
- $(CAPCHILD_SRC)
+ $(libcapchild_a_SOURCES)
checkapi-todo:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
-sourcedir=$(srcdir) \
- $(CAPCHILD_SRC)
-
-EXTRA_DIST = \
- $(GENERATOR_FILES) \
- CMakeLists.txt \
- doxygen.cfg.in \
- Makefile.common \ No newline at end of file
+ $(libcapchild_a_SOURCES)