aboutsummaryrefslogtreecommitdiffstats
path: root/capchild/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'capchild/CMakeLists.txt')
-rw-r--r--capchild/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/capchild/CMakeLists.txt b/capchild/CMakeLists.txt
new file mode 100644
index 0000000000..af4a1cbc58
--- /dev/null
+++ b/capchild/CMakeLists.txt
@@ -0,0 +1,46 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+
+set(CAPCHILD_SRC
+ capture_ifinfo.c
+ capture_sync.c
+)
+
+set(CLEAN_FILES
+ ${CAPCHILD_SRC}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
+
+add_library(capchild STATIC
+ ${CAPCHILD_SRC}
+)
+
+set_target_properties(capchild PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+set_target_properties(capchild PROPERTIES FOLDER "CAPCHILD")