aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a5895b73b..5138c5311e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1015,6 +1015,10 @@ if(ENABLE_BCG729)
set(PACKAGELIST ${PACKAGELIST} BCG729)
endif()
+if(ENABLE_AMRNB)
+ set(PACKAGELIST ${PACKAGELIST} AMRNB)
+endif()
+
if(ENABLE_LIBXML2)
set(PACKAGELIST ${PACKAGELIST} LibXml2)
endif()
@@ -1145,6 +1149,9 @@ endif()
if(BCG729_FOUND)
set(HAVE_BCG729 1)
endif()
+if(AMRNB_FOUND)
+ set(HAVE_AMRNB 1)
+endif()
if(LIBXML2_FOUND)
set(HAVE_LIBXML2 1)
else()
@@ -1455,6 +1462,11 @@ set_package_properties(BCG729 PROPERTIES
URL "https://www.linphone.org/technical-corner/bcg729/overview"
PURPOSE "Support for G.729 codec in RTP player"
)
+set_package_properties(AMRNB PROPERTIES
+ DESCRIPTION "AMRNB decoder"
+ URL "https://sourceforge.net/p/opencore-amr"
+ PURPOSE "Support for AMRNB codec in RTP player"
+)
set_package_properties(LIBXML2 PROPERTIES
DESCRIPTION "XML parsing library"
URL "http://xmlsoft.org/"
@@ -1713,6 +1725,9 @@ if(WIN32)
if (BCG729_FOUND)
list (APPEND OPTIONAL_DLLS "${BCG729_DLL_DIR}/${BCG729_DLL}")
endif(BCG729_FOUND)
+ if (AMRNB_FOUND)
+ list (APPEND OPTIONAL_DLLS "${AMRNB_DLL_DIR}/${AMRNB_DLL}")
+ endif(AMRNB_FOUND)
if (LIBXML2_FOUND)
list (APPEND OPTIONAL_DLLS "${LIBXML2_DLL_DIR}/${LIBXML2_DLL}")
endif(LIBXML2_FOUND)
@@ -2901,6 +2916,9 @@ if(RPMBUILD_EXECUTABLE)
if (BCG729_FOUND)
list(APPEND _rpmbuild_with_args --with bcg729)
endif()
+ if (AMRNB_FOUND)
+ list(APPEND _rpmbuild_with_args --with amrnb)
+ endif()
if (LIBXML2_FOUND)
list(APPEND _rpmbuild_with_args --with libxml2)
endif()