aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2010-05-28 20:19:55 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2010-05-28 20:19:55 +0000
commit47e2d75820ee02066a61e341034aace6d28063c1 (patch)
treed70498d786146b2e819ee680cc26ba8c90fd167e /wsutil/Makefile.am
parent17807a6b21c50a72e3bc11ddf0ff7bc2b313823a (diff)
Move some code (including the optional objects) into libwsutil
svn path=/trunk/; revision=33012
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am30
1 files changed, 26 insertions, 4 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 461557d45c..84a643b6cf 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -28,24 +28,46 @@ if HAVE_WARNINGS_AS_ERRORS
AM_CFLAGS = -Werror
endif
+# Optional objects that I know how to build. These will be
+# linked into libwsutil.
+wsutil_optional_objects = \
+ @GETOPT_O@ \
+ @STRERROR_O@ \
+ @STRNCASECMP_O@ \
+ @STRPTIME_O@ \
+ @INET_PTON_LO@ \
+ @INET_NTOP_LO@
+
lib_LTLIBRARIES = libwsutil.la
INCLUDES = -I$(srcdir)/..
-libwsutil_la_SOURCES = \
+libwsutil_la_SOURCES = \
$(LIBWSUTIL_SRC) \
$(LIBWSUTIL_INCLUDES)
-libwsutil_la_LIBADD = @GLIB_LIBS@
+libwsutil_la_LIBADD = \
+ @GLIB_LIBS@ \
+ $(wsutil_optional_objects)
-EXTRA_DIST = \
+EXTRA_DIST = \
Makefile.common \
Makefile.nmake \
file_util.c \
file_util.h \
+ inet_ntop.c \
+ inet_pton.c \
+ inet_v6defs.h \
libwsutil.def \
+ strerror.c \
+ strerror.h \
+ strncasecmp.c \
+ strptime.c \
+ strptime.h \
unicode-utils.c \
- unicode-utils.h
+ unicode-utils.h \
+ wsgetopt.c \
+ wsgetopt.h
CLEANFILES = \
libwsutil.a \