aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2012-04-04 20:46:49 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2012-04-04 20:46:49 +0000
commit75c3c92f197406d14eb213e30a07955928517399 (patch)
tree6ec908c62bfc2115e32c3e747e90ad14f3552744 /wiretap/Makefile.am
parent02e0b847f15c5045bbf15b13d555c619fc8b36c9 (diff)
Add a "-build" argument to checkAPIs.pl. Use that argument when building
from makefiles (and thus from the buildbot). The intention is to be able to tell when a human is running the tool so we can provide more code-review guidance. As a starter, enable the "too many proto_tree_add_text() calls" check when a human is running the tool. svn path=/trunk/; revision=41943
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index 1dabf1ee1a..0ee92af674 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -102,4 +102,4 @@ dumpabi: all abi-descriptor.xml
checkapi:
## 'abort' checking disabled for now pending resolution of existing use of g_assert & g_error
## $(PERL) ../tools/checkAPIs.pl -g abort -g termoutput $(NONGENERATED_C_FILES) $(GENERATOR_FILES)
- $(PERL) ../tools/checkAPIs.pl -g termoutput $(NONGENERATED_C_FILES) $(GENERATOR_FILES)
+ $(PERL) ../tools/checkAPIs.pl -g termoutput -build $(NONGENERATED_C_FILES) $(GENERATOR_FILES)