aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-19 08:03:08 +0100
committerJoão Valverde <j@v6e.pt>2016-04-21 18:59:56 +0000
commit3db13a7fc9f08fdb238f06e73a42b39396fee84c (patch)
tree13962d67e01b8d0f15aed5e6216ae584c23bd991 /wiretap/Makefile.am
parent7c6e859ccf210a45e1cc0f6da17692845e6b5a23 (diff)
Link version code statically again
This allows keeping the code-sharing with the static linking. This "fixes" a hypothetical ABI mismatch with wsutil and avoids pulling more external dependencies to wsutil than strictly necessary. A nice side-effect is that libwsutil no longer depends on version.h. Follow up to f95976eefcbeb5d24df383c29d29ef888b503945. Change-Id: I8f0d6a557ab3f7ce6f0e2c269124c89f29d6ad23 Reviewed-on: https://code.wireshark.org/review/15002 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index 597e77d27b..6414645942 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -36,6 +36,9 @@ CLEANFILES = \
libwiretap_generated.la \
*~
+DISTCLEANFILES = \
+ ws_version_info.c
+
MAINTAINERCLEANFILES = \
$(GENERATED_FILES) \
Makefile.in
@@ -46,14 +49,15 @@ MAINTAINERCLEANFILES = \
#files with the "stop on warning" barrier.
libwiretap_la_SOURCES = \
$(NONGENERATED_C_FILES) \
- $(NONGENERATED_HEADER_FILES)
+ $(NONGENERATED_HEADER_FILES) \
+ ws_version_info.c
libwiretap_generated_la_SOURCES = \
$(GENERATED_C_FILES)
libwiretap_generated_la_CFLAGS = $(GENERATED_CFLAGS)
-BUILT_SOURCES = $(GENERATED_HEADER_FILES)
+BUILT_SOURCES = $(GENERATED_HEADER_FILES) ws_version_info.c
EXTRA_DIST = \
.editorconfig \
@@ -82,6 +86,9 @@ ascend.c: $(srcdir)/ascend.y ascend_scanner_lex.h
fi
$(AM_V_YACC)$(YACC) -d -p ascend -o ascend.c $(srcdir)/ascend.y
+ws_version_info.c: $(top_srcdir)/ws_version_info.c
+ $(LN_S) $<
+
# ABI compliance checker can be obtained from
# http://ispras.linux-foundation.org/index.php/ABI_compliance_checker
# Checked using version 1.21.12