aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorMaksim Salau <maksim.salau@gmail.com>2019-06-27 21:20:02 +0300
committerAnders Broman <a.broman58@gmail.com>2019-08-03 15:46:08 +0000
commit9011ad10303a99f1d4e6547ee39d33040fdb52d5 (patch)
tree1bb6d439b46618ce9bf6be6b00fbd93a1e8756cc /wiretap/CMakeLists.txt
parent19488f334dfe8d1cf8bc0a80726069e88a2f6335 (diff)
wiretap: Add support for Busmaster log file format
Only CAN protocol is supported. Extra information available in J1939 entries is ignored since the J1939 wireshark dissector works with raw CAN frames and makes no use of this extra information. The log format may also encapsulate LIN messages which are not supported by wireshark and thus are ignored. The only limitation is that relative timestamp format is not supported. If a file defines relative format of timestamps, packets are extracted, but timestamps are omitted, since random access deems impossible without reparsing the whole file up to the packet of interest. In order to support relative timestamps we need to parse the whole file at once on open and either dump into a temporary PCAP file or keep messages in a private list and provide access to them on read()/seek_read(). The change also creates a separate header for CAN frame structure definitions which are used by several file readers (candump and busmaster for now). Bug: 15939 Change-Id: I87c5555e4e5e1b142b9984b24544b2591d494fbc Reviewed-on: https://code.wireshark.org/review/34083 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 319e677f93..720aab05ab 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -24,6 +24,7 @@ set(WIRETAP_NONGENERATED_FILES
atm.c
ber.c
btsnoop.c
+ busmaster.c
camins.c
candump.c
capsa.c
@@ -89,6 +90,7 @@ set(WIRETAP_FILES ${WIRETAP_NONGENERATED_FILES})
add_lex_files(LEX_FILES WIRETAP_FILES
ascend_scanner.l
+ busmaster_scanner.l
candump_scanner.l
k12text.l
)
@@ -98,6 +100,7 @@ add_yacc_files(YACC_FILES WIRETAP_FILES
)
add_lemon_files(LEMON_FILES WIRETAP_FILES
+ busmaster_parser.lemon
candump_parser.lemon
)
@@ -160,6 +163,7 @@ CHECKAPI(
# LEX files commented out due to use of malloc, free etc.
# ${LEX_FILES}
${YACC_FILES}
+ ${LEMON_FILES}
)
#