aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorРоман Донченко <dpb@corrigendum.ru>2014-08-24 23:23:45 +0400
committerGraham Bloice <graham.bloice@trihedral.com>2014-08-31 22:14:15 +0000
commit95cd6b76bdf0230b60d82bc3dff8f3387b7ac8cc (patch)
treeb8e4698ef22aaaa71244c8f85209b881aaab17b5 /ui/qt/Makefile.am
parent4f95327eb9723f54566761dcbee7b05883ad18f8 (diff)
Remove make-tapreg-dotc and its uses, since Python is now mandatory
Change-Id: I13fd57a288be68d18819826bf566ed7b5688ebaa Reviewed-on: https://code.wireshark.org/review/3926 Reviewed-by: Evan Huus <eapache@gmail.com> Petri-Dish: Evan Huus <eapache@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index d1e9c7b903..3ea7b5444c 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -59,14 +59,9 @@ MAINTAINERCLEANFILES = \
# The first argument is the directory in which the source files live.
# All subsequent arguments are the files to scan.
#
-wireshark-tap-register.c: $(WIRESHARK_QT_TAP_SRC) $(top_srcdir)/tools/make-tapreg-dotc $(top_srcdir)/tools/make-tap-reg.py
- @if test -n "$(PYTHON)"; then \
- echo Making wireshark-tap-register.c with python ; \
- $(PYTHON) $(top_srcdir)/tools/make-tap-reg.py $(srcdir) taps $(WIRESHARK_QT_TAP_SRC); \
- else \
- echo Making wireshark-tap-register.c; \
- $(top_srcdir)/tools/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_QT_TAP_SRC); \
- fi
+wireshark-tap-register.c: $(WIRESHARK_QT_TAP_SRC) $(top_srcdir)/tools/make-tap-reg.py
+ @echo Making wireshark-tap-register.c
+ @$(PYTHON) $(top_srcdir)/tools/make-tap-reg.py $(srcdir) taps $(WIRESHARK_QT_TAP_SRC)
RUNLEX=$(top_srcdir)/tools/runlex.sh