aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-08-18 11:46:12 -0700
committerGerald Combs <gerald@wireshark.org>2015-08-20 23:12:37 +0000
commit2ed3d91b45332a2cbb4114b61f18c80fb28a6840 (patch)
tree1c37bec81ce931d54d8e0a3f59812dcdfe9c505f /ui/qt/CMakeLists.txt
parent0f9bbbc6f7146747841760102a74efb96161ad99 (diff)
Add the WLAN statistics dialog.
Instead of splitting the stats into two lists as with the GTK+ UI, add everything to an expandable tree. This allows viewing nodes on more than one network. Rename the top-level Bluetooth menu item to Wireless and put the WLAN stats dialog there. The Qt UI matches SSIDs (WlanNetworkTreeWidgetItem::isMatch) a bit differently than the GTK+ UI. Try to make the logic as plain as possible since we'll likely have to update it in the future. The addition of a custom BSSID address types means that we can't assume that everything is AT_ETHER. Add routines for checking for broadcast BSSIDs and comparing only the data portions of addresses. Move PercentBarDelegate into its own module. Use it in WlanStatisticsDialog. Change-Id: Ie4214eb00671a890871380c4a07213ebfb7585c6 Reviewed-on: https://code.wireshark.org/review/10171 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index b43922fedb..b19093f7c0 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -92,6 +92,7 @@ set(WIRESHARK_QT_HEADERS
packet_list.h
packet_list_model.h
packet_range_group_box.h
+ percent_bar_delegate.h
preference_editor_frame.h
preferences_dialog.h
print_dialog.h
@@ -132,6 +133,7 @@ set(WIRESHARK_QT_HEADERS
wireless_frame.h
wireshark_application.h
wireshark_dialog.h
+ wlan_statistics_dialog.h
)
if(HAVE_PCAP_REMOTE)
@@ -224,6 +226,7 @@ set(WIRESHARK_QT_SRC
packet_list_model.cpp
packet_list_record.cpp
packet_range_group_box.cpp
+ percent_bar_delegate.cpp
preference_editor_frame.cpp
preferences_dialog.cpp
print_dialog.cpp
@@ -292,6 +295,7 @@ set(WIRESHARK_QT_TAP_SRC
sctp_all_assocs_dialog.cpp
sctp_assoc_analyse_dialog.cpp
stats_tree_dialog.cpp
+ wlan_statistics_dialog.cpp
)
set(WIRESHARK_QT_FILES