aboutsummaryrefslogtreecommitdiffstats
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2016-05-31 18:29:39 -0700
committerGerald Combs <gerald@wireshark.org>2016-06-01 23:37:25 +0000
commit987ff3ee1bed5fe17d3889411687283818cee29f (patch)
tree32a8079efadab5f0a51b06db69bcf16701f92035 /ui/CMakeLists.txt
parent4b216aea944b0478fa0310b2e47a11761219ffe8 (diff)
Qt: Firewall Rules dialog.
Add the Firewall ACL Rules dialog. Try showing all valid rules for a given product instead of making the user select from a combobox. We can add the combo back easily enough if that's desired. Add a rule hint field and use it in the Qt and GTK+ UIs. Bug: 12469 Change-Id: I39dd840e9838f96d7c5e2b4c34662811c21d0386 Reviewed-on: https://code.wireshark.org/review/15689 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index 28d1ab00cf..8145dd1dee 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -33,6 +33,7 @@ set(COMMON_UI_SRC
export_object_tftp.c
export_pdu_ui_utils.c
help_url.c
+ firewall_rules.c
iface_lists.c
io_graph_item.c
language.c