aboutsummaryrefslogtreecommitdiffstats
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-01-14 17:25:56 -0800
committerGerald Combs <gerald@wireshark.org>2015-01-30 06:48:32 +0000
commit2bf7878e8a7455fe656bb07e9a7d42e6ac4d87fd (patch)
tree3a0c99831311c43017d1d9b3336856e4a956c353 /ui/CMakeLists.txt
parent6824cee6c4b5f7c00b9dc4e9013aaa936b18b739 (diff)
Qt: Add the RTP Streams dialog.
Add keyboard shortcuts. Note that not all of the buttons made it from GTK+. Add a "Go to setup frame" option. Move rtp_streams.c from ui/gtk to ui. Add a help URL for RTP analysis (which needs to be split into streams + analysis). Fix RTP stream packet marking. Change-Id: Ifb8192ff701a933422509233d76461a46e459f4f Reviewed-on: https://code.wireshark.org/review/6852 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index 35efca9977..214d54f8a2 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -43,6 +43,7 @@ set(COMMON_UI_SRC
profile.c
proto_hier_stats.c
recent.c
+ rtp_stream.c
software_update.c
ssl_key_export.c
tap_export_pdu.c
@@ -58,6 +59,12 @@ set(COMMON_UI_SRC
voip_calls.c
)
+# Enables visibility in IDEs
+file(GLOB EXTRA_UI_HEADERS
+ rtp_analysis.h
+ rtp_stream.h
+)
+
set(DIRTY_UI_SRC)
add_lex_files(DIRTY_UI_SRC