aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2007-08-30 00:24:40 +0000
committerGerald Combs <gerald@wireshark.org>2007-08-30 00:24:40 +0000
commit92802883a6ec5192b9df1ab7b3d4d8069b46f841 (patch)
tree956ab91ef804104bde2f208b6425b01233d6f4b8 /tools/Makefile.am
parent4e83fc82878f4037921bb688e8559abf5701e856 (diff)
Change the "--enable-setuid-install" option to install dumpcap and TShark
setuid instead of Wireshark. Remove the "DANGEROUS" notices, but leave it disabled by default. Whine if the user runs Wireshark or TShark as root. Add a preference to disable the whining. Add a "setuid-root" script that can be used to switch dumpcap and TShark's setuid-ness on and off for development and testing. Update the release notes and README.packaging. svn path=/trunk/; revision=22733
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 4bb4a22458..847a06a621 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -103,6 +103,15 @@ EXTRA_DIST = \
wireshark_gen.py \
yacc.py
+noinst_SCRIPTS = setuid-root.pl
+setuid-root.pl: setuid-root.pl.in Makefile
+ sed \
+ -e 's,@BIN_PREFIX\@,$(bindir),' \
+ -e 's,@TSHARK_BIN\@,$(tshark_bin)$(EEXT),' \
+ -e 's,@DUMPCAP_BIN\@,$(dumpcap_bin)$(EEXT),' \
+ < setuid-root.pl.in > setuid-root.pl
+ chmod +x setuid-root.pl
+
MAINTAINERCLEANFILES = \
Makefile.in